Lua Debugger
6 6

40 posts in this topic

Recommended Posts

 

To fix it on Linux, open projectzomboid.sh and put in

-Ddebug \

 

Does this still work in 26? I've added it (same as I added in 25c) but F11 isn't working. I've been busy for a couple weeks so maybe I've missed something. I find I'm lost without it now. :)

Share this post


Link to post
Share on other sites

Might have to add it after the call to zombie.gameStates.MainScreenState now:

zombie.gameStates.MainScreenState  -debug
No longer seems to work with the -D flag.

Share this post


Link to post
Share on other sites
How i can get debugger in build 27 #1.

OS: Win 8.1

Bought the game on the Steam.

 

When i add -debug/-Debug/-D I'm getting in console Unknow option "__OPTION_NAME__"

With LShift no luck too.

 

I'm sorry for my bad English.

Share this post


Link to post
Share on other sites

-dDebug

No, this is also trigger error Unknow option.

".\jre64\bin\java.exe" -Xms1024m -Xmx1024m -Djava.library.path=./ -cp lwjgl.jar;lwjgl_util.jar;./ zombie.gameStates.MainScreenState -dDebugPAUSE

Share this post


Link to post
Share on other sites

 

-dDebug

No, this is also trigger error Unknow option.

".\jre64\bin\java.exe" -Xms1024m -Xmx1024m -Djava.library.path=./ -cp lwjgl.jar;lwjgl_util.jar;./ zombie.gameStates.MainScreenState -dDebugPAUSE

 

I put the flag in wrong place:
 
This is working:
 
".\jre64\bin\java.exe" -Ddebug -Xms1024m -Xmx1024m -Djava.library.path=./ -cp lwjgl.jar;lwjgl_util.jar;./ zombie.gameStates.MainScreenStatePAUSE

Share this post


Link to post
Share on other sites

Hi guys I'm having some problems here:

Before , i could launch the game in debug mode perfectly. Later I didn't have the option to play solo , online. And now I can't even open the debug mode even If i press shift before launching the game , after launching the game , when the console open, it simply doesn't seems to work. I tried to make the -debug or -Ddebug but I don't know where to place it can you guys help me?

 

I'm using windows 10

 

Edit: Pressing 5 on the numbers of the right seems to disable the Hud , and pressing slowly the left shif key seems to work , still want to know where I need to place the -debug code.

Edited by axeladalidez78

Share this post


Link to post
Share on other sites

You place -Ddebug  in the bat file, after the xmn/xmx values. You do not need to hold any special keys to activiate it. F11 will bring up the Lua debug panel once in game.

Share this post


Link to post
Share on other sites

 

On 5/2/2014 at 11:21 PM, EnigmaGrey said:

Might have to add it after the call to zombie.gameStates.MainScreenState now:

 


zombie.gameStates.MainScreenState  -debug

No longer seems to work with the -D flag.

I'm trying to get the debugger working with linux on 38.30 steam multiplayer. It doesn't seem to matter where I put -debug/-Ddebug/-dDebug I've tried adding each of those three before -Xms1024m, after -Xmx1024m , and after zombie.gameStates.MainScreenState. I still can't get f11 to open the debugger. Java version openjdk version "1.8.0_151"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
6 6