Archived

This topic is now archived and is closed to further replies.

  • 0

Intel integrated graphics crash

Question

If Build 26 crashes when starting up, and you have an Intel GPU (not AMD or NVidia), and you see this error in the hs_err_XXX crash log in the ProjectZomboid folder:
J  org.lwjgl.opengl.GL15.nglBindBuffer(IIJ)VJ  zombie.core.VBO.GLBufferObject.glBindBuffer(II)V

Unzip the attached file into the ProjectZomboid directory, then run either the MAP_BUFFER_32.bat or MAP_BUFFER_64.bat and let us know if it fixes anything.

MAP_BUFFER.zip

Share this post


Link to post
Share on other sites

31 answers to this question

Mine crashed as well. Really gutted as I only brought the game today. Demo worked fine but the full game won't allow me to play for more than one second.

http://pastebin.com/fe6aVTKe

If you disable 3D models in Options then press Save, it should work. :)

Share this post


Link to post
Share on other sites

Great Odin's raven it worked! If this zombie outbreak ever ends I shall knight you Sir Nullified. Thanks.

Share this post


Link to post
Share on other sites

I'm interested in seeing your console.txt files from these failed runs too.  The .bat files turn on OpenGL debugging which might show some new error.

Share this post


Link to post
Share on other sites

Alright so how do you disable the 3D models?

Set it to player only?

(Jesus my 700th post)

Share this post


Link to post
Share on other sites

Alright so how do you disable the 3D models?

Set it to player only?

(Jesus my 700th post)

Set it to none, surprisingly enough.

Share this post


Link to post
Share on other sites

Plot twist.

Load up build 26 (Already put map buffer on)

Ran from steam in compatibility mode, suddenly the None option is there. Check it off, Game works fine.

Oh wait that was the problem the whole damn time.

Anywho, What was I suppose to do again?

Share this post


Link to post
Share on other sites

If you could run one of the MAP_BUFFER .bat files with 3D models on, and paste the console.txt output onto pastebin.com and link to it here, there might be a useful error in it that will indicate what causes the crash.   I was hoping to help people who have crashes with models turned off though.

Share this post


Link to post
Share on other sites

You are correct, sir.  :cry:

 

I do notice your OpenGL version reported as "OpenGL version: 2.1.0 - Build 8.15.10.2993" is old.  OpenGL 4.4 is the current version.

Updating your drivers straight from Intel might help.

Share this post


Link to post
Share on other sites

I uh have the newest drivers.. I don't think any intel card supports openGL that high though..

Share this post


Link to post
Share on other sites

What's your graphics card, Silents? I know we've had this conversation before and there's probably even a dxdiag.exe floating around, but I've seen several dozen the past few days and can't quite remember.
 

 

You are correct, sir.  :cry:

 

I do notice your OpenGL version reported as "OpenGL version: 2.1.0 - Build 8.15.10.2993" is old.  OpenGL 4.4 is the current version.

Updating your drivers straight from Intel might help.

Intel (and other graphics card manufatures) stop providing implementations of OpenGL at some point. Most people just don't have the option to update to the latest version of OpenGL. :(

Share this post


Link to post
Share on other sites

Intel HD graphics 1000

And yeah, Intel supports OpenGL horribly.

You should see a new update out.

Check if, in Options, the game now has NOT SUPPORTED BY HARDWARE for 3D models.

Build ID should now be 271188.

Does it?

Share this post


Link to post
Share on other sites

 

Intel HD graphics 1000

And yeah, Intel supports OpenGL horribly.

You should see a new update out.

Check if, in Options, the game now has NOT SUPPORTED BY HARDWARE for 3D models.

Build ID should now be 271188.

Does it?

 

Im lost. A new update for the game or the intel card? Because my drivers are up to date.

How do I check the build ID ?

And I don't remember anything saying my hardware wasn't supported when I adjusted options in game. Back in the days when I needed compatibility mode for smooth framerate it said unsupported hardware for shaders, but now that I don't use compatibility mode, I don't have that message.

Share this post


Link to post
Share on other sites

Hi all,

 

My game crashes every time I load into the actual game. I've updated my drivers, JRE, and I've tried the MAP_BUFFER/3D models/etc fixes on this thread. I always run it on compatibility mode and I'm on build 26 (at least that's what the game lobby says).

Here's my crash log: http://pastebin.com/8ZWdVrmZ (it's my latest one, one didn't seem to generate after I tried the MAP_BUFFER thing)

 

Edit: Reinstalled the game and deleted my %user%/Zomboid folder, tried the MAP_BUFFER batch file again, and it worked!

Share this post


Link to post
Share on other sites

Just curious but whats the OpenGL requirements for this game? Intel HD supports up to 2.1 fully.


Also I tried reinstalling the driver, and for the hell of it I clicked the installer again but oddly this is the only driver that doesn't warn me saying the driver or a newer driver is already installed, it just goes on like its the most updated. Feels odd.

 

Share this post


Link to post
Share on other sites

Intel HD supports up to 2.1 fully.

Unfortunately the reality of Intel's OpenGL support, especially on Windows, often differs from what it says on the tin.

 

There is no official OpenGL level requirement right now. All this 3D fixing, troubleshooting etc is part of the process of figuring that out.

Share this post


Link to post
Share on other sites